Advertisement

Find answers, ask questions, and connect with our community around the world.

  • PowerScribe 360 & Headsets

    Posted by Unknown Member on August 15, 2014 at 11:02 am

    I know this has probably been asked before but is anyone out there using a headset with PowerScribe 360?  If so are you still using a foot petal as well?  I imagine there are keyborad and voice shortcuts for lots of the basic commands so I would like to hear if so what people are doing.
     
    Thanks.

    vascular28_304 replied 1 year, 11 months ago 4 Members · 7 Replies
  • 7 Replies
  • Unknown Member

    Deleted User
    August 28, 2014 at 5:09 pm

    Haven’t seen anybody using the foot pedal with it, but 2.5 lets you use a headset to dictate and a mic to toggle dictation/fields.

  • Unknown Member

    Deleted User
    August 29, 2014 at 5:09 am

    I have several rads that are using headsets with PS360 2.0 but know this: In order to get the headset to properly play and record sound, you must unplug the headset while launching PS (the PowerMic must stay plugged in). Once the voice profile is fully loaded, you can then plug in the headset and it’ll work correctly. I’ve been told there is a fix for this in 360 v2.5 but I haven’t tested it yet. No foot pedals or transcriptionists here. Good luck!

    • vascular28_304

      Member
      August 1, 2022 at 11:47 am

      Old thread but I was looking for answers to why some of my workstations with powerscribe seem to “stop seeing the mic” at times. 
      What happens if they plug the headset in before voice profiles load?
       
      what behavior do you see?

      • martz_cabrera

        Member
        August 4, 2022 at 11:17 am

        We’ve had that issue. Theoretically, the PowerMic is pulling too much power from the USB port. Try an externally powered USB hub.
         
        We are replacing our computers, and the issue is cropping up again – haven’t tried the external USB hub again yet.

        • vascular28_304

          Member
          August 4, 2022 at 11:26 am

          Thank you Neurorad!  We replaced one workstation because it was older, but a few days later the issue cropped up exactly the same in our 1 year old computer.  We upgraded firmware and minded all of our Ps and Qs but your answer makes much better sense. 

        • michele.mcguire_299

          Member
          August 5, 2022 at 7:04 am

          Turn off the power saving in USB. That might help your issue

          • vascular28_304

            Member
            August 5, 2022 at 7:54 am

            thank you pacsdrone.